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Version 8.6.5 (DB 3.3.6) 

 Diagram Annotations 
o This will allow you to write annotations for each diagram. The annotations are 

printed underneath the diagram on the summary and full-page diagram pages of 
the cath report. 

o Click-and-drag a number to the diagram to reference an annotation. Multiple 
numbering styles and formatting options are available. 

o If annotations are present when generating the patient diagram template, they will 
be stored with the patient template and will imported into reports where the 
template is used.  

o Annotations are available in the stand-alone atlas and will be included on the 
diagram printouts. 

o Option to embed the annotations beneath the diagram when copying the image to 
the clipboard or saving to a file. This can be done by right-clicking the diagram on 
the Browse screen or by clicking the buttons on the Patient Edit screen. 

 Added McGoon Ratio and dAO diameter field (and %normal) to the measurements tab. A 
pop-up box was added to show the calculations for PA Index, PA Area Index, and the 
McGoon Ratio. 

 Find Form updates 
o Added ability to search by cath number when in view-by-patient mode. 
o Modified behavior when searching by cath number in view-by-cath mode so that 

exact matches will be searched prior to looking for partial matches. Also, the search 
is now case-insensitive. 

o Added an information box to provide details on searching by internal IDs. 
 Added a start-menu shortcut to launch directly into the stand-alone atlas.  
 Settings Transfer and Backup/Restore 

o Ability to transfer global settings and hemo system mappings from an external 
PedCath database. The global setting differences are displayed to the user and the 
user can select which settings should be transferred. This can be used to facilitate 
setting up a test environment and rolling tested settings back into production. 

o Back up a snapshot of your PedCath settings and hemodynamic import mappings. 
Restore the settings at a later date if needed. 

 LDAP improvements 
o Fixed connection issues when connecting via LDAPS. 
o Added server bind option to speed up the connection when connecting directly to a 

host. 
o Added additional authentication options. 
o Added additional checks when testing the connection. 

 Hemodynamic import updates 
o Updates to Siemens Sensis import to allow for more robust enumeration and date 

processing under different regional settings. 
o Hemodynamic mapping tables are now automatically backed up if any mapping 

changes are made during a database upgrade. 



 Fixed date controls on HL7 log viewer. 
 Fixed issues with image auto-selection in the report setup when printing the cath report 

from the Browse screen. In prior versions all images would be printed by default regardless 
if a subset of images was previously saved. Also, the default selection was erroneously 
reported as 0/n. 

 IMPACT Registry 
o Any access data that is synced from the cath report has been made non-editable 

within the IMPACT module.  
o The patient’s ZIP code is validated to contain 5 digits. 

 Added option to not require symbols in passwords (some symbols can be problematic 
under some character sets). (Requires SSS support to set). 

 Added support for custom Dx code sets to allow for new code sets in the future without 
requiring a PedCath upgrade. 

 Refined shutdown procedure for better memory and resource management. 
 Improved cleanup of cath resources and records when a cath report is deleted. 
 Added command line option -pe for specifying an encrypted password. Encrypted 

passwords may be generated using the CVIS Simulator tool. 
 Fixed issue regarding the export log (pc8_export.csv) and HL7 exports. If a path is 

specified for HL7 file exports and doesn’t have a trailing backslash, then those entries in 
the log file wouldn’t contain the backslash between the path and file name. 

 Added procedure code to administrative fields form and fixed issues that could prevent 
some field updates from saving under certain circumstances. 

 Fixed issues with HL7 OBR segment numbering. Under certain configurations the 
numbering would be off. 

 Admin Console 
o PNG files now included in the hemodynamic folder cleanup during maintenance. 

 Interfacing changes 
o XML v3.5 

 Added diagram annotations. 
 Added dAO diameter and McGoon ratio. 
 Adverse events code description was missing and was added in. 

o HL7 v3.4 
 Added diagram annotations. 
 Added dAO diameter and McGoon ratio. 

 

 
Version 8.6.4 (DB 3.3.4) 
 

 Added support for autosave on the Edit Cath screen.  
o This is a per-user option and can be enabled by choosing File > Autosave from the 

menu.  
o The report will be automatically saved every 2 minutes when changes have been 

made and the Edit Cath screen is idle. 
o For reports added with the Add Cath button, the autosave feature will not go into 

effect until the report is manually saved once by the user. 



o The autosave feature does not run while the user fields section has the focus, due 
to the automatic packing of user sites when the report is saved. 

 Added ability for undo and redo functions on the Edit Cath screen. 
 Import Updates 

o A lab name filter has been added to the filter options dialog in the import module. 
This will allow you to filter the results shown to one or more labs. The import filters 
are set per workstation. 

o Added a reload button and a legend to import files screen. 
o Fixed issues regarding registered labs that could potentially cause issues when 

registering labs from multiple system types under certain conditions.  
o Siemens Sensis: Added ability to sort the procedure log tables by time. Contact 

Scientific Software for assistance in setting this up. 
 Staff Listing Updates  

o Added ability to include the last login date for each staff member on the staff listing 
printout. Users who have not logged in after upgrading to 8.6.4 will have a blank 
last login date. 

o The reactivate user command wasn’t allowing over 4 characters for the login name. 
This has been fixed to support up to 20 characters.  

 Access Sites Updates 
o Fixed run time error 9 when deleting either a vein or artery list item when only one 

item remains. 
o Made the closure methods form resizable. 

 Fixed issue when using the date picker (calendar) form to set the cath date, birth date or 
other dates. In prior versions if you open the calendar control and click the X to close the 
form rather than Cancel or Ok, it will set the date to the last date that was chosen on the 
calendar control, or 12/30/1899 if a date hadn’t been set using the calendar form yet.  

 Updated the inactivity timer check to handle more scenarios to prevent the user from being 
booted off while they’re working. This includes checks when typing in the comments 
section, navigating to and editing all edit screen controls, and some other navigation 
options.  

 Document Editor 
o Fixed issue if a new document is created and saved multiple times without exiting 

the editor, PedCath would prompt you for the title on each save and create a new 
document each time.  

o Fixed document editor not displaying the document title after a save. 
 Fixed issue when adding a user diagram (affected version 8.6.3 only). You would receive 

the error: “Error 204--2147417848: Automation error. The object invoked has disconnected 
from its clients.” Scientific Software can assist with a work-around if you are running 
version 8.6.3. 

 Added check for the main form/splash screen as well as pop-up forms to make sure they 
are entirely on screen and will reset the position if not.  

 Data Reports:  Fixed “error 508-91 Object variable or with block not set” in data reports 
when creating a CSV file. Scientific Software can assist with a work-around if you are 
running version 8.6.3. 

 Added ability to view the list of imported OBR-4 codes in the HL7 setup.  
 Audit Logging Updates 

o Added support for more robust audit logging. If the Visual C++ runtime 2015-2022 
dependencies aren’t installed the logging will still work. However, the Visual C++ 
runtime is still required if the log file permissions are locked down to append-only.  



o When editing a cath report, now only a single entry is logged during the first edit 
saved while the user is on the editor screen for a particular cath report, rather than 
including a log entry for every change.  

 Fixes to the 8.6.2 and 8.6.3 DB updates which could lock up or cause errors under certain 
circumstances.  

 UI stability improvements. Better handling of double-button clicks and closing out of the 
import window when it is still loading. 

 Added ability to view the internal cath id, patient id, and staff ids on the browse and staff 
edit forms when hovering the mouse over the number.  

 The CRISP calculator will use a local config file if one isn’t found on the network. 
 Admin Console 

o Fixed error 700 DBF database format error when applying a DB setting. The error 
can be ignored in prior versions.  

o Fixed DB editor message saying edited text fields were truncated (due to trailing 
spaces). 
 

 
Version 8.6.3 (DB 3.3.3) 
 

 Added support for multiple access sites.  
o One or more arterial and venous access sites may be added to the cath report 

which each include the access site, sheath size and closure methods.  
o Closure methods can optionally be printed along with the access information. This 

is a per-cath report setting that can be auto-set with a global setting. The format of 
the closure methods is also configurable. 

o Overriding the report text is still supported.  
o For the IMPACT Registry, access data is now only sync’d one way from the cath 

report to the IMPACT module. Only the largest sheath access for vein and artery 
will be transferred. The data is editable within the IMPACT module and will not be 
overwritten if left off of the cath report. 

 Document Manager 
o Added the ability to view the Edit screen while working on a document in the 

document manager. With the document editor open choose View > Edit Screen 
from the menu or press Ctrl+E. Some Edit screen functions are not available while 
in this mode. Also be aware that the document will not be selectable while certain 
screens are open such as the Dx and Comments forms. 

o Styles are now available in the document editor (e.g., Normal, Header 1). Styles 
can be modified for individual documents, and your institution can also define a 
global stylesheet to be used for all new documents by pointing to a Word document 
with the styles set as desired. Enabling a global stylesheet can be turned on in the 
options on the Administrator tab > Misc panel. 

o The default document descriptions for new documents will now be set to the first 
line of the text in the document rather than “Document n”. 

o When importing documents, some additional file types will be shown in the default 
filter (PDFs (if enabled), html, and p7d files). 

 Changed encryption method (to AES 256-bit) for some database fields to improve security. 
Encrypted items include passwords, user access, patient SSN (if used), export profiles, 
LDAP settings, etc.  



 On the Browse screen the first patient is no longer auto selected after the grid is loaded. 
When viewing by cath or by staff, the first record is no longer auto selected on the cath and 
staff grids. 

 New HIPAA log in CSV format. The log may be viewed within the new Admin Console 
viewer (which includes filtering) or using an external spreadsheet program. The new format 
will allow the log to be locked down to prevent tampering and allows viewing only by 
authorized staff. It combines the data from the two existing HIPAA logs and now includes 
both identifiers and flattened data (e.g., Patient id and name). This format improves the 
viewing performance (whether within the Admin Console or an external spreadsheet 
program). Your PedCath administrator or IT staff should set the permissions on the log file 
as desired. Please see the PedCath HIPAA Log Configuration white paper for more 
information. 

o Additional events are logged in this release. 
o An optional log item (Patient views on the browse screen) can be configured in the 

Audit Logging options on the Administrator tab. It is turned on by default. 
o The log location can be modified in the options as well. 

 Personnel Database 
o Added ability to import staff using a CSV file. This will allow you to create new staff 

members as well as update existing staff members. PedCath will allow you to 
export the staff list as a CSV file or a blank CSV file to work from. This feature can 
be found from the staff listing form, by clicking the “Import/Export” button. See the 
on-screen help for more information. The staff files will be automatically backed up 
prior to importing data. 

o The Personnel Database form now indicates which users need a password reset 
due to being locked out due to exceeding the number of invalid attempts (if 
enabled).  

 Diagram Editor 
o Fixed issue with version 8.6.2, where if you erase something and click the area it 

will make selecting other tools unresponsive. 
o Added an option to make the eraser marks selectable in the diagram editor. This is 

needed as a work-around for the following scenario. If you erase a section and 
draw over it (or add text) then you may not be able to select the item due to it being 
directly above the erased area. This is because the drawing component selects the 
bottom object first – however because the eraser marks aren’t selectable you won’t 
be able to select anything directly above it. But when the option to select eraser 
marks is enabled, if you right-click the item you are trying to move/edit multiple 
times it will cycle through the drawing marks stacked on top of each other from the 
back to the front and you will be able to select it. This is a per-workstation setting 
found on the Options menu within the diagram editor.  

 Another workaround for this scenario (which will work in 8.6.2 as well), 
would be to save the diagram or use the flush command (Action > Flush) 
after drawing with the eraser tool. Both of those commands will “flatten” the 
image so that the eraser mark and other drawings will become part of the 
image. 

o Added tooltip text for the eraser tool. 



 Updated global and user options tables to use variable length fields for the values. Values 
that were spanned across multiple fields in prior versions are now stored in a single record. 

 HL7 export 
o Added an option to override the OBX-3 tags for the text-based report segments. 

The default is 10012-01^TEXTREPORT.  
o Fixed issues with OBX numbering. When using the option to strip out all OBR 

segments except for the first, a few of the OBX numberings (OBX-1) would be 
duplicated or skipped. 

 GE MacLab - Added support to import the procedure start and end times from the event 
log. To do so add the tag similarly to “EVENT|Case Start” to either your procedure date or 
time mapping in PedCath. The text after the pipe character is the text as it will appear in 
the log where you’d like to extract the time. It’s recommended to use a macro on the 
MacLab so that the text is consistent for each case.  

 Siemens Sensis Vibe – added support to pick up PDF files during the hemodynamics 
import if available.  

 Active Directory/LDAP updates 
o Added option to allow select workstations to use local logins instead of LDAP. This 

can be helpful for shared workstations. The setting can be found on the General tab 
in the options. It must be set by an administrator.  

o Added a button in the admin console maintenance to disable LDAP. This will allow 
you to login to PedCath using local credentials if the server is down or to 
reconfigure it if the service account credentials have changed. The button can be 
found on the Maintenance tab. 

 IMPACT Registry 
o Automatic sync of the largest sheath for vein and artery from the cath report. 

Closure methods are editable within IMPACT if not entered on the cath report. 
o Replaced the cath lab arrival date with the procedure date/time on the missing 

discharge and error reports. The forms are also now resizable. 
o The stand-alone episode of care form now checks that cath reports are within the 

episode time frame using the procedure start/end dates rather than cath lab arrival 
dates. 

 Interfacing changes 
o XML v3.4 

 Added vein and artery access data to support multiple access sites.  
 Removed the elements venaccess, vnsheathsz, artaccess, and atsheathsz, 

which represented the largest sheath size. 
 
Admin note: Be aware that because the password encryption is changing, after installing the software 

you will not be able to log into the admin console until the PedCath database is upgraded. If you 
use the Admin Console’s login table feature to see who’s logged in and to boot users off during an 
upgrade, it’s recommended to do so with your current version before installing the upgrade. 

 
Version 8.6.2 (DB 3.3.2) 
 

 Institutional site labels on the user fields tab can now be overwritten on individual cases at 
any time, and up to 8 can be pre-defined in the options. The site labels will pre-load on new 
and existing cases until user sites measurements are added to the hemoset and the case 
is saved. Any rows without measurements will be removed. With regards to the 



hemodynamics import, you can import into up to 8 user sites. Import site labels that match 
the institutional sites defined in the options will be automatically mapped to user sites. Any 
other user sites that you’d like to bring in would need to be set up in the mappings. 

 Extended Vein/Artery free-text field sizes.  
 Added support for HL7 acknowledgement processing. Users who export the cases will be 

notified if cases are rejected by the EMR (or timed out) (and optionally ones that are 
accepted). Reports that are rejected can be automatically unlocked. This is a file-based 
interface and requires the acknowledgement files are sent to a transfer folder. 

o This can be set up in the options:  
 Tools > Options > Administrator > Export 
 Under advanced export options click HL7, and select the ACK Handling tab. 

o Manual processing and a log viewer can be accessed from the Browse screen 
Tools menu (under HL7 ACK Processing). 

 Added additional HL7 export formatting options.  
 
 Added ability to install license and logo files through the PedCath interface.  

o To do this go to the main menu: Help > About 
o Click the Install License button and browse to the file location.  

 Document Manager  
o Added ability to add multiple documents to the Document Templates (“My Cath 

Documents” and “Network Documents”) at once. 
o Now when adding/importing documents into a template folder with the folder 

selected, documents are added to the end of the folder rather than the beginning. 
o Support for document template file names and descriptions to be greater than 40 

characters. In prior versions if the file name was longer than the maximum you 
would get error 710-715 File extension not recognized when attempting to access 
the document.  

 Diagram Editor 
o Added Eraser tool. 

 C3PO export 
o The single export now allows for setting the C3PO id when the cath is locked. 
o Batch export 

 Added support for showing cases that have already been exported.  For 
cases where the C3PO Ids have not been set, they can be entered by typing 
into the grid. 

 Added column sorting ability. 
 Added ability to export the grid to a CSV file. 

 The lab name (what’s shown on the Direct Data Import Utility) will be imported into the cath 
record and can be included on the cath report and other export formats. Check off “Print 
lab name” in the report setup options to include it on the cath report. The lab name can be 
viewed or changed from the Edit screen by going to View > Administrative Fields. Not all 
hemodynamic systems will send over the lab name and those that are able to may need to 
be configured. 

 Added support to include Comments and Dx Comments in the data reports CSV export. 

 Admin Console 



o Several updates have been made to improve the responsiveness of the View Login 
Information tab. 

o If a login record for a user is cleared before the user is booted out, the user’s 
PedCath instance will be automatically closed. 

 Ability to turn off the export log (pc8_export.log).  
o Tools > Options > Administrator > Export 

 Export filename format form updates 
o Allows additional fields to be present that will meet the requirement for a unique file 

name (such as the accession number, order number, study GUID, or timestamp).  
o Spaces are now supported in the file name. 
o Lab name can now be included in the file name. 

 Interfacing changes 
o XML v3.3 

 Added measurement log data to the XML export and import. 
 Added lab name. 

o HL7 v3.3 
 Added lab name. 

 HTML export 
o Added lab name. 
o Added user sites data. 

 CVIS/Command line interface updates 
o Ability to launch to the cath edit screen for a specified case, or to the import screen 

if the report doesn’t exist. With this method the calling system will not need to track 
the PedCath report creation status. 

o Fixed issues when using patient-only data files. 
o Fixed parsing errors when launching PedCath using the pedcath: protocol link 

under certain conditions. 
 Cath diagrams and images inserted within a document editor document were linked to files 

by default in earlier versions. They are now embedded within the document. Cath diagrams 
would likely show as a broken link because they were linked to local temporary files. 

 Fixed error "137-55: File already open" when importing a hemodynamics file. If the config 
file impstrings.dat was used to remap fields from your hemodynamics system such as the 
gender string, you will get this error on subsequent imports during your current session.  
The error does not cause issues in earlier versions.  

 Fixed issue where you would be prompted to enter a document title when exiting the cath 
report in certain circumstances. 

 
 
Version 8.6.1 (DB 3.3.1) 
 

 Added ability to create and manage the patient diagram template directly from the browse 
screen and patient edit form. This will allow you to create/edit and print the template at any 
time. Creating a cath report ahead of time is no longer necessary for the purpose of 
creating the template. This will allow you to print the template for the patient or staff prior to 
the procedure. 

o Add or edit a template from the Edit menu (or press Ctrl+T) with the patient 
highlighted. 



o If a template exists, it is shown on the patient edit form. Here you can print, copy it 
to the clipboard, and save to an image file. Patient demographics can be included 
on the printout. 

 Added ability to archive patients to backup tables to reduce the size of the database, which 
should improve performance. 

o Users can flag (or unflag) individual patients for archival on the browse screen Edit 
menu. 

o Batch operations are available in the administrator console. Administrators can flag 
all patients for archival who haven’t had a cath procedure in a specified number of 
years, or flag patients using an MRN list. 

o Administrators can retrieve patients from the archive in the administrative console. 
o Patients records flagged for archival or retrieval are processed during database 

maintenance. 
 Added a user option to select the email protocol (MAPI vs Outlook object model) that is 

used when attaching reports to emails from the report setup, billing codes module, and 
data reports. We have discovered the MAPI interface doesn’t support launching a 64-bit 
version of Outlook from a 32-bit application (PedCath). If you receive errors when 
composing emails from PedCath (such as 127-48389 and run time error 32053) and are 
running Outlook for your email client, it’s recommended to change the setting to Outlook 

object model.  The setting can be changed by going to Tools > Options and clicking the 
User tab.  

 Added the -63 billing code modifier in the billing codes module for patients less than 4 kg. 
 Added new Dx/Billing code global sync options. By default, any workstation that is set to 

sync codes (based on the existing per-workstation option) will copy newer codes from the 
network to use in PedCath so there will not be a user prompt. These options can be found 
on the “Coding” panel in the administrative options. 

o "Sync all workstations on startup":  PedCath will compare the local copy of the 
billing and diagnosis codes to the files in the network folder at startup on all 
workstations. This overrides the per-workstation setting found on the General tab. 
The user will be prompted as to which version should be used (unless the choices 
below are checked). 

o "Always use newer version": The user will not be prompted at startup but PedCath 
will use whichever codes are newer. If the codes in the network folder are newer 
they will automatically be copied locally. 

o "Copy local to network if newer": Local codes that are newer than what's in the 
network will be copied to the network without a user prompt. This will make the 
locally installed codes available to all users. 

 Fixed search by Id in patient filter search on the Patient Browse screen.  
 GE MacLab updates 

o The latest update to the MacLab would cause the gender to come over into 
PedCath as Unknown. PedCath can now handle the updated format. Other imports 
have been given greater flexibility as well in case the import tags are changed in the 
future.  

o Added ability to fix .docx Word documents sent from MacLab that come over as 
blank. Contact Scientific Software if you are experiencing this problem. 

o Added ability to use the same mapping for the cath date and procedure start 
date/time. 



 Fixed error when importing multiple images into the image manager at the same time with 
regards to saving the path to the registry for future sessions. Also, the setting is now a per-
computer-user setting rather than a machine setting. 

 Fixed issue where the Dx comments from a patient’s previous case may load automatically 
into the Dx module on a newly created case. A work-around for this when running prior 
versions is to save the newly created cath report before entering the Dx module. Choosing 
to import prior Dx codes will also blank out the Dx comments.  

 On the edit screen if the procedure end date was deleted in prior versions it wouldn’t be 
saved, now it will. The procedure end time will be automatically blanked out if the 
procedure end date is erased. Blanked out times will not transfer to the IMPACT Registry 
module. 

 If any invalid filename characters are in any of the export fields (such as the MRN) in the 
export field name are now stripped out of the file name.  

 Added checks if PedCath isn’t able to read the DB version (possibly from a corrupt or 
missing globalop.nsx index file). PedCath will now show an error and quit. Prior versions 
would spawn the database update and would blank out your cath database if run. This is 
likely recoverable with help from Scientific Software. 

 Fixed issues with the IMPACT Registry related to the study status. In prior versions if an 
IMPACT study was deleted and the cath report was later modified, then the icon next to the 
case on the browse screen would indicate the IMPACT study was in progress. 

 Admin Console: 
o Added additional fields to the new id check in database maintenance. 
o Added option to store cath and Dx comments in individual case files to improve 

loading performance and prevent corruption. This option can be found on the 
Maintenance tab. 

o Patient archival manager.  
 Maintenance tab > Under Other Maintenance click the “Patient 

Archival/Retrieval” button. 
o Patients records flagged for archival or retrieval are processed during database 

maintenance. (DB options would need to be checked). It’s recommended to turn on 
“Remove Deleted Records” as an option for database maintenance when moving 
records to and from the archive. 

o Fixed a few HIPAA log type descriptions that would display as blank in the listing: 
"Deleted Staff Record",  "Imported New Case" , and "Imported Into Existing Case". 

o Fixed issue with HIPAA record backup function on the HIPAA tab.  
 
 
 

 
 
Version 8.6.0 (DB 3.3.0)  
 

 Added Seckeler method to the O2 consumption calculator. 
 Added authentication options 

o Ability to change the minimum password length (between 8 and 15). 
o Ability to force password resets after a specified number of days. 
o Ability to prevent password reuse. The number of previous passwords compared is 

configurable (up to 9). 
o Ability to disable an account after a specified number of invalid login attempts (up to 

9). 



 Added support for ICD-11 codes in the billing module. Which ICD set(s) are available to 
users can be configured in the administrative options. The CPT code updates for 2023 are 
also included. 

 Added ability to copy a diagram to the clipboard within the diagram manager and by right-
clicking the diagram preview on the browse screen. 

 Document Editor updates 
o Added toolbar buttons to change the indention level and added the ability to 

increase/decrease selected paragraphs indention level by pressing Tab or Shift-Tab 
(more than one line would need to be selected). 

o Character formatting options: additional sub/superscription options, text casing 
options. 

o Paragraph formatting options: Can set frame border line color, and background 
color. 

o Text frames options: can set double-line, and line color. 
o Added support for table formulas.  

 Improved performance when loading grids on browse form. 
 Export log updates 

o Changed export log from a fixed field-width text file to a csv file ‘pc8_export.csv’. 
This includes several new fields (Cath Id, Cath Number, Account Number, A full file 
path (not truncated), Report status). 

o When the PDF is embedded within the HL7, in prior versions it was being included 
as a separate record in the log. This has been taken out. 

 Fixes to command line options 
 Some fixes when errors occur during HL7-file generation. 
 When Thermo CO is used for the calculations, the calculations did not show when 

hemoglobin was missing. This has been fixed. 

 
Version 8.5.9 (DB 3.2.2)  
 

 Added support for a legacy MRN. This can be useful when switching EMR systems, 
changing the MRN formatting, or when using the multi-site toolkit (sharing data between 
children’s and adult centers). 

o PedCath will track which cath reports should use the legacy MRN on the printed 
reports and exports vs ones that should show the current MRN. If all MRNs will 
change at once you can set a global transition date (the last date the legacy MRN 
should be used) in the options. In the case of the multi-site toolkit where patients 
would transition to the adult center at different times, you can specify a transition 
date per-patient (which will override the global setting if set). You can also specify 
which MRN to use on individual cath reports (Edit Menu > Use Legacy MRN) which 
will override the transition dates. 

o All cases set to use the legacy MRN will show it on the printed cath report, text 
report, XML, HL7 and HTML exports. 

o The XML export also include two additional fields (legacy_hrn and current_hrn). 
o This feature can be turned on or off in the administrative options (turning it off will 

not remove the legacy MRN data). 
o When importing data from your hemodynamics system with the direct data utility 

when the legacy MRN field is enabled: 
 PedCath will import into an existing patient record if the MRN in the file 

matches either a current or legacy MRN in the database. 



 If one or more patients are found who match the same first, last name and 
birth date but not the MRN, the user will be given an option to match the 
patient record (which if imported will update the current MRN, and optionally 
set the existing MRN to the legacy and set the transition date) or to create a 
new patient. The import into existing cath feature on the edit screen will also 
search for matching cases based on the legacy MRN. 

o The Find function on the browse screen will search over both the current and 
legacy MRN fields. 

o The legacy MRN is viewable/editable on the patient edit form..  
o The legacy MRN will be added as a field in data reports and added as a field in the 

CSV extract. 
o If the legacy MRN is being used for a cath report, then it will be shown on the edit 

cath screen but will be grayed out and non-editable. 
 Expanded study GUID to 64 characters in cath table for all users. 
 GE MacLab/CardioLab 

o Added support to import IMPACT Registry values from MacLab (or CardioLab) 
custom fields. 

o Added support to import pressures and saturations from site labels that contain 
spaces. 

o Fix to error (126-380) when importing IMPACT Registry data from CardioLab, when 
a subset of the data elements is chosen for import. 

 Data Reports 
o Added descriptions to IMPACT Registry other events in the CSV export. 
o Added support for adverse events in the CSV export.  

 Stability fixes for the browse screen. 
 Added support for different concurrent licensing configurations for the multi-site toolkit. 
 Fix to syncing the billing codes set at startup. 
 

 
Version 8.5.8  
 

- For users with version 8.5.7 only:  Fixed issue when importing data from your 
hemodynamics system into an existing case from the browse screen (Tools > Import Cath 
Data). This is a less common workflow so the issue may not affect your organization. 

During the import the currently selected cath report on the browse screen would be moved to 
the patient record who is being imported, and some data fields and documents/images may 
have been overwritten depending on the overwrite options chosen.  

o If you are running version 8.5.7 it’s recommended to choose the Import Into Current 
Cath option on the Edit screen in order to import data into an existing cath. This 
method does not have the issue. 

o To fix existing cases that have this issue, you would highlight them and choose Edit 
> ‘Move Cath Report’ to move them back to the correct patient record. (This 
requires an administrator account within PedCath). It’s recommended to reimport 
the data with the File > ‘Import Into Existing Cath’ command. It’s recommended to 
delete the hemodynamic sets before importing. Any diagrams or custom documents 
shouldn’t be affected. 

- IMPACT Registry – the cath lab arrival date is no longer used in the validation. This is an 
IMPACT v1-only field that could be set through the hemodynamics import and isn’t 
changeable by the user. 

- Administrative Console 1.3.7 



o Added ability to boot all users at once. 
 
 
Version 8.5.7 (DB 3.2.1) 
 

- Support for export folder override with the multisite toolkit. 
- Fixed a scenario where the cath lock edit time and staff member could get updated with the 

wrong information. A utility will run during the database update to correct any records that 
have issues, by comparing the cath values to the HIPAA logs. (The issue would occur if 
you attempted to import a case that was already in the system, as a new case; whether the 
case was imported or not, the lock staff and last edit time of whatever the currently 
selected cath report was on the browse screen would be updated to the current user and 
time.) 

- Fixed issues with mismatched images/documents with Siemens Sensis import. This is only 
an issue if you are also using a GE MacLab or Schwarzer import. If a MacLab or 
Schwarzer case are imported, then subsequent Sensis cases imported within the same 
session would use any images or documents found from the last MacLab or Schwarzer 
case. 

- Fixed issue if importing into an existing cath and the case isn’t imported. If the user then 
clicks the print preview command on the browse screen, PedCath will show the information 
from the import file rather than the case selected on the browse screen. 

- IMPACT Registry 
o Fixes for users running date formats other than mm/dd/yyyy, such as dd/MM/yyyy. 

The IMPACT forms would display dates as mm/dd/yyyy and could save the date 
incorrectly if the study was resaved.  The dates for the CSV extracts were also 
fixed. 

- Admin Console 1.3.6 
o Fixed issue when applying settings files that have a bracket in the value. 
o Includes error codes/descriptions in maintenance when there are issues packing or 

reindexing the tables. 
 
 
Version 8.5.6   
 

- CRISP calculator updates 
o Added ability to label the temporary CRISP data created from the Browse screen. 
o Fixed report setting that indicates whether to print the CRISP score. In the prior 

release, the checkbox would always show as unchecked regardless of the setting. 
- LDAP fixes 

o New staff records created at startup through the LDAP interface would not show in 
the staff list picker on the Edit screen when manually adding staff members to the 
cath report. 

- Added ability to support a full-header logo, to replace the header lines. 
- MacLab custom fields 

o Fixed MacLab custom fields when working with hemodynamics and added ability to 
map to all 8 sets instead of just the first.  

o Added support to import cath numbers with MacLab Custom Fields.  
- Fixed issues affecting machines configured for extended (double-wide) character sets. 

o Fixed issue with saving/loading FTP profiles. 
o Fixed issue with vein/artery labels overlapping on the report if vein is not set. 



 
 

Version 8.5.5  (DB 3.2.0) 
 

- Updates to CRISP Calculator workflow: Added the ability to temporarily save CRISP score 
data that’s not linked to a patient (i.e. when the calculator is launched from the Browse 
screen), and import that data into a cath report at a later time. The CRISP data is labeled 
with the currently logged-in user’s username and a sequence number. If the data is not 
imported into a case within 7 days, it will be automatically deleted. 

- Document Manager fixes 
o The document preview was not refreshing when toggling between PDF documents. 
o Added PDF and HTM/HTML to “all files” filter when importing files. 

- IMPACT  
o Fixed issue with saving IMPACT diagnoses codes after importing diagnoses from 

previous cases. The diagnoses codes would not save unless they were also 
manually changed. This issue only occurred with the Dx module if you are using 
IMPACT codes for the PedCath report. The other code imports (prior surgeries and 
procedures) did not have this issue.  

- Batch Export 
o Added “Auto Exports” as a choice, which if selected will export all file formats set up 

in the options auto-export list over a date range. This includes the file exports, FTP 
profiles, and other interfaces (such as Lumedx Apollo). If the IMPACT transfer 
module is active, the user will be given a choice as whether to include those as 
well. 

- Fix to clean up any duplicate records for settings when saved. 
 

 
Version 8.5.4  (DB 3.1.9) 
 

- Added CRISP scores for risk assessment. The score and CRISP variables are saved with 
each cath record and are searchable in data reports. Please contact Scientific Software for 
assistance enabling this feature. 

o On the Edit screen select Tools > Calculate CRISP Score from the main menu. 
- Added multi-site support. This will allow multiple hospitals (that share a network) to use a 

shared PedCath database. PedCath will track where each cath procedure was performed 
and create reports based on the performing site’s header and logo. Members of one site 
can access reports from the other sites (as view-only), or hide them on the browse screen. 

- Active Directory/LDAP  
o Added a configuration to allow managing the permission level within PedCath. For 

this configuration a single active directory security group is needed indicating that 
the user has PedCath access. 

o Fixed issue where if a new PedCath user chooses to create a new staff record at 
startup, the record would not be successfully created (instead there would be a 
blank record, which will show in the staff listing). This issue affects versions 8.5.0 -> 
8.5.3 only, and a work-around is to create any new staff records within the PedCath 
staff listing interface prior to the user attempting to log in.  

- Imports 
o Ability to import 0 for radiation values (fluoro time, contrast, rad dose and total 

DAP), if 0 is found in the import file (rather than assuming not measured). 
o Prevent importing data into locked cases. 



o Fixed issue where imported user site values may contain a trailing period. 
- Cath Report 

o Added an option to print the user sites in a grid within the left-hand column of the 
summary page (before or after the comments and diagnoses). The chosen user 
sites location will be applied to the expanded calculations and measurement pages 
as well. If the sites are printed in the right-hand column there is a limit of user sites 
that will print on the summary page (6 for the single-logo header and 3 for the dull-
logo header). This limitation does not apply if the user sites are printed in the left-
hand column. All user sites are included on the expanded calculations and 
measurements pages regardless of the settings.  

 That can be set on the “Options” tab in the report setup 
(“Dx/Comments/User Sites Options…” button).  

o Fixed issue with printing multiple associated hemosets on the summary page where 
additional sets past the last one associated with the diagram were being included. 

o If a summary page right column wraps to the next page, the Dx list and comments 
will be printed at the top of the next page rather than the bottom. 

- HIPAA/Audit logs 
o Added log entries for importing a new case and into an existing case. 
o No longer log when a new cath is created (before it’s saved), which was being 

logged as a cath id=-1. 
- Fix to code set sync (Dx/Billing code sets). If the network files had a major or minor version 

number that is 2 digits, then it would always prompt you to sync at startup. 
- Fixed error when setting the IMPACT episode of care under the Dx screen under certain 

conditions. 
- Fixed issue with embedding measurements in the diagram if the diagram editor window is 

stretched across an ultra-wide monitor or across multiple monitors. At a certain width the 
numbers would be in a larger font and shifted.  A work-around for prior versions is to make 
the form a smaller size and then save the diagram after the numbers are embedded. 

- Fixed issue when loading PO2 values in the calculation overrides, when using a decimal 
separator of anything other than a period (.) in the Windows regional settings. 

- Admin Console 
o Added ability to batch merge duplicate patient records, who’s MRNs differ only by 

leading 0s. 
o Fix to DBF Extract for some newer lookup tables with memo fields. 

- C3PO-R3 
o Fixed issue with batch export 
o Export schema update  

- Fixed the IMPACT Registry option that links the MRN to the Other ID when using the 
IMPACT transfer module. The option didn’t load until either the IMPACT administration 
options or IMPACT demographics form was opened. This is not related to generating 
quarterly submission files. 

 
 

Version 8.5.3 
 

- Fixed issue with the XML batch export to correctly include IMPACT procedure/diagnoses 
codes in cases where they are used for the cath report.  

- Fixed issues with importing into an existing cath report. If free text was entered into the 
vein/artery boxes (overriding the radio buttons), then the report values would revert to the 
default text based on the radio values. 



- Enforce 20-character limit for the vein/artery override fields. 
- Added support for additional date formats that contain spaces (such as d. M. yyyy) 
- Fixed issue when verifying old passwords during a password change.  This affected 

versions 8.5.0 -> 8.5.2 if a user used a complex password prior to upgrading. A work-
around for versions 8.5.0 -> 8.5.2 would be to retype the old password with all capital 
letters when resetting the password, or to have an administrator reset the password. 

 
Version 8.5.2 
 

- Fixed issue importing the placer order number from the GE MacLab and Philips 
Xper. If multiple cases were imported within the same PedCath session, the order 
numbers would be set the same as the first imported case.  

 
Version 8.5.1 
 

- Fixed patient race issue from 8.5.0 DB update (Field was shortened from 8 to 3 
characters in initial release). Users who installed the PedCath 8.5.0 update that 
was downloaded prior to 11/19/2019 will need to run the following utility to fix the 
field and populate data from DB backup.  

o http://www.pedcath.com/dl/PedCath850PatientRaceFieldFix.exe  

- Fixed data reports issue with the CSV output (it would not always include the 
hemodynamics in the export for all cases. If one of the cases had 0 sets then the 
rest in the file would be blank). 

- Fixed bug with auto-refresh of the patient grid. Patients deleted would be brought 
back into the user interface on the workstation where they were deleted. Any 
operations on that patient would result in an error.  

- Fixed Schwarzer hemodynamic import issues:  Errors 126-9 and 137-55.  
 

Version 8.5.0 (DB 3.1.8) 
 

- Complex passwords are now required. Passwords must be at least 8 characters 
long, with at least one upper and lower case letter, a number, and a symbol.  All 
users will be required to reset their password upon startup following the upgrade. 
The default password for new users or for users after a password reset is now 
Taussig1! 

- The patient grid on the patient browse screen will now be automatically refreshed to 
keep in sync with patient records added or modified by other users. 

- Added support for using an external image editor to edit the heart diagrams. The 
editor would be launched from the Diagram Editor as an additional function (the 
original PedCath editor will still be available). Any editor used would need to retain 
the original filename and image resolution.  

o To set this up go to Tools > Options > General tab > More, and enter the full 
program path (command line switches are also supported). This is a per-
machine setting. 

Ex:  For Windows Paint enter:   



C:\Windows\system32\mspaint.exe 
 

- IMPACT Updates 
o C3PO-R3 export – Submit data already entered into the PedCath IMPACT 

module to C3PO-R3. A batch export feature is available as well to export up 
to 10 cases at a time. 

o Ability to choose which IMPACT coding sections appear on the cath report, and well 
as the ordering.  

 From the main menu choose IMPACT Registry > Administration, and on the 
general tab click the  … button next to “Use IMPACT coding for PedCath 
Dx”. 

 This is a global setting and will affect all reports. 
o Fixes to handling shared IMPACT/cath report fields such as access sites and 

coding for locked cath reports. 
 Ability for the IMPACT clinician to create updated cath reports when 

attempting to edit IMPACT codes that are locked, to enable editing. 
 Coding sections that are not included on the cath report will remain editable 

when the cath report is locked. 
o Fixed IMPACT creatinine units from mg/mL to mg/dL to match the coding 

instructions. 
o Fixed PA Stent procedure device outcome wording so it would save correctly (“Not 

deployed” to “Stent not deployed”).  
o Added ability to import some IMPACT pre-procedure measurements, if available 

from your hemodynamics system. 
o Ability to have SSN N/A set by default for new patients (without deleting old SSNs). 

Contact Scientific Software for assistance setting this. 
 

- Exports 
o written to export folder will track all exported cases.  

 Fields:  Export Time, MRN, Patient Name, Cath Date,  File Path, Staff 
Name, Trigger Type,  Source Host, Whether an error occurred  

o XML 
 Added NPI and institutional staff id to XML export in both the sign block and 

the staff listing. 
 IMPACT Registry codes will now be included in the XML export if you are 

using them for the PedCath report. 
o Batch Export 

 Fixed errors that occurred with the batch export when running for an 
extended amount of time (when generating diagrams (within the PDF, or as 
image files)).  

- Data Reports updates 
o Ability to add all procedure/Dx/events codes within a tree folder to a query with a 

button click.  
o Fixed cath date query when “Last Year” is selected. 
o Added code numbers to IMPACT Dx and specific procedures in the data reports 

CSV export. 
o Fixed issue when querying on IMPACT procedure codes that have an equals sign 

in the description. 



o Fixed adding IMPACT codes to a query for View Only users. 
o Additional fixes. 

- Document Manager updates 
o Ensure template documents that are given the same title as an existing document 

gets a unique file name. In earlier versions it’s possible that existing template files 
could be overwritten by new ones with the same name, when added with the Create 
New button. 

o Fixed errors when deleting template folders or documents, where the source file 
doesn’t exist. 

- Misc 
o Additional integrity checks when assigning database record IDs. 
 

- Admin Console 
o Database Maintenance: Added a data field checker to the integrity check that will 

check/reset any numeric or date fields that have invalid data. 
o Disabled registry check at startup. 

 
Version 8.4.6 
 

- Measurement Log – PedCath will generate a hemodynamics measurement log for all 
hemodynamic monitoring systems during the import. The log will include all pressures, 
saturations, and other hemodynamics as well as procedure notes along with timestamps if 
available. The log will be saved to the document manager and there is also an interface 
available on the Edit screen to pop-up the log to view the hemodynamics for the active 
hemoset (View > Measurement Log (F11).) PedCath will allow you to copy values from the 
log to the edit screen boxes (on the hemodynamics tab, user fields tab, and calculation 
overrides) by clicking and dragging the individual measurements. PedCath will also allow 
you to copy all pressures (syst/dias/mean) at once by clicking and dragging the site label 
from the log to the site name on the hemodynamics tab or the site name on the user fields 
tab. 

- Imports 
o Added direct data import for Schwarzer kardiotek Evonatal. 
o Updated user interface layout on the Import review screen (e.g. The Import button 

is now on the right side of the screen to be more consistent with other forms). 
o A date range filter has been added to the Direct Data Import Utility. This will allow 

you to view only files exported from your hemodynamics system within a given date 
range. Click “Filter Options…” to set the filter.   

o The mapping button is now hidden for all users by default. To make the mapping 
button visible for your account (an administrator account is required): 

 Tools > Options > User tab > More button 
 Check “Show import mapping configuration button”. 

o The lab name is now shown as a column on the Direct Data Import Utility to show 
where each import file originated from.  

o Fixes to setting up registered labs (Lab Licenses). 
o CardioLab (EP) improvements - Updated interface to make IMPACT registry data 

more easily readable on the import review screen.  
o If the import file does not contain the radiation dose or total DAP, PedCath will now 

set the units to the default units specified in the options.  
- IMPACT Registry 

o Removed Arrhythmia Spontaneous Resolved field under the Events panel. 



o When using the IMPACT codes on the PedCath report, it’s possible that the 
fundamental diagnosis code would be listed twice if it was also set in the pre-
procedure diagnoses list. The code will now be included in the list only once. 

o The generated IMPACT Dx codes list on the Dx form, that will allow you to copy 
them to the Dx comments would always list “Hgb Prior to Transfusion: ...”, whether 
it was set or not. This has been fixed. 

o The IMPACT registry panel will now show automatically rather than the 
hemodynamics on the PedCath Edit screen, if the study is specified as an EP Cath 
or EP Ablation Procedure. 

- C3PO Registry 
o Some user interface updates to submission form. 
o Fixed some issues where the submission files would contain schema errors under 

certain conditions, and would not be accepted by C3PO.  
- Changed registry check to occur on value saves rather than startup. This will allow 

PedCath to run without write access to HKEY_LOCAL_MACHINE after the registry values 
(such as the network data path and import path) have been set by an administrator. The 
error message will now only be shown when values are attempted to be changed and fail. 

- For 2-logo header layouts: Repositioned the “signed by” text so that it doesn’t overlap with 
the account number (if present) on the bottom of document pages. 

- Fixes to some date formats with a non-numeric month (such as dd-MMM-yyyy). The HIPAA 
logging did not work correctly and the report signed-by-message wouldn’t show when using 
this format.  

- When locking a cath report, a summary of cath resources (e.g. diagrams, images, 
documents) will be displayed for review prior to locking. 

- Fixed issues with auto-increment cath number (affected 8.4.5 only). 
- Ability to update one or more global settings by applying a .P7S file in the administrative 

console.   
 
 
Version 8.4.5  
 

- Added procedure total time with start and end times to the cath report and exports. 
- Browse screen views: 

o Added ability to set the default view used on the Browse screen. 
 Tools > Options > User tab > More > Default View 

o Added additional views on Browse screen: 
 View By Recent Cath – Will show the 30 most recent cases. Scrolling to the 

bottom of the grid will load additional cases.  
 Patient Filter Search – Will allow searching for patients based on Name, ID 

or MRN.  No patient records will show in the patient grid initially. 
- Added option to use the date/time of the server for cath locking.  (Tools > Options > 

Administrator > Report Locking) 
- Mullins Atlas updates 

o Ability to log in directly to the diagram atlas to print and edit temporary copies of 
diagrams, without viewing any patient data. The login is (u: atlas  p: atlas).  This is a 
licensed feature.  

o The add patient template to cath feature has been added directly to the Diagram 
Manager screen. It was also moved to the top of the Atlas screen. 

o Added ability to filter the User atlas and longer descriptions are now supported.  



o Diagram supplement updates are available. (Click the Update Atlas.Supplement 
and choose View Updates under the Update Supplement section). 

o Fixed issues with mirroring function when switching diagram variations. 
- IMPACT 

o Fixed schema conformance errors with submissions of follow-up data. 
o Fixed Rad Dose (Air Kerma) could incorrectly show as out of usual range on the 

completeness report.  
o Fixed issues where the IMPACT module would always prompt you to save under 

certain conditions when leaving the module. 
o The procedure start/end times are now entered on the PedCath report. If they are 

entered they will automatically flow into the IMPACT module and will be not be 
editable there. 

o IMPACT integer-value fields taken from the PedCath report (such as the radiation 
values) that are entered between 0 and 1 will be rounded up to 1 when sent to 
IMPACT. 

o 11103 TPVR Final Balloon Pressure had the incorrect units (it was mmHg, and 
fixed to be atm(s)). 

- Data Reports: 
o Added procedure start, end and total times as searchable fields. 
o Made the Total DAP and Rad Dose fields in the CSV extract match your default 

units and labeled them in the header. 
- Exports 

o Fixed HL7 issues when including the contents from Document Manager documents. 
Line breaks would not be stripped out of the text correctly causing split OBX 
segments.This affected versions 8.4.3 and 8.4.4 only. 

o Added option to include document manager contents in the XML file. 
o Updated FTP transfer control. 

- Fixed Lafarge age reported on the top of the O2 consumption calculator. The age reported 
may not match the age used in the calculation, shown in the calculation details (which is 
correct) over a couple day time span before the birthdate. 

- Import Fixes: 
o Fixed issues with PedCath losing the import path when set the same as the 

PedCath network directory. 
o Fixed issue for Merge and McKesson imports where the import files could not be 

automatically deleted after the import giving error 220-55. 

o Fixed: MacLab custom fields won’t import if Show Files of Type was set to All 
Licensed Import files. Setting that to MacLab .h7c will work as a work-around in 
previous versions. 

o Support for Sensis modified cath date format. 

- Billing codes 

o The description text within the coding tree, search, and cath codes list are now 
wrapped to show the entire descriptions without scrolling. The highlighted item’s 
text is no longer shown at the bottom of the screen. 

o Fixed the -22 button. It was not always updating to show the value of the selected 
code. 

- Added some efficiency improvements. 

- Additional Fixes. 
 



- Admin Console Updates 
o HIPAA updates - Ability to resize the forms, view the original file ordering, and save 

results to a csv file. 
o Added ability to print a PedCath workstations list to show all machines that have 

logged into PedCath. This can be helpful in determining what machines use 
PedCath for updating/maintenance purposes. 

o Added ability to back up HIPAA logs during the database update, to reduce the 
active file size. The HIPAA viewer will include the backup files. 

o Added ability to merge duplicate staff records. 

 
 
Version 8.4.4  
 

- The last edit time of a cath report and staff member are shown on the Edit screen status 
bar. 

- IMPACT updates  
o The supporting definitions are now shown on the main IMPACT forms. 
o Fixes to patient merge and move cath report functions. 
o The EP Targets and Catheters tabs are now hidden for EP diagnostic caths where 

an ablation was not planned or performed. Also the EP tab is now shown in the 
follow-up section when either an ablation or EP cath was done (it was not being 
shown for EP cath in prior versions). 

- Updates to Command line interface 
o Ability to import a hemodynamics file with the filename 
o Ability to load the IMPACT forms directly for a patient. 

- Diagram Editor updates 
o Option to always save the diagram to the network when the save button is clicked 

(rather than just to the local cache). To enable this choose Options > Always Save 
to Network from the menu within the diagram editor. 

o Fixed issues with save reminder. 
- Added SSH support for LDAP (LDAPS) and fixed issues connecting to ports other than 

339. 
- Fixes to login handling. 
- Added staff record modifications and error reports to the HIPAA log. 
- Full-Edit staff members will only be able to edit accounts of No-Access records. 
- Fix when importing documents during MacLab import (a blank row would show in the 

associated files in earlier 8.4 releases). 
- Fixes to Merge import (affected 8.4.3 only). 
 
- Admin Console Updates 

o Added ability to re-index tables at startup if the admin console didn’t shut down 
properly. This is necessary if an index is corrupt. 

o Fixed issue where packing tables in maintenance wouldn’t work correctly when 
certain options are selected. 

 
 
 

 
Version 8.4.3  



(Database Schema v3.1.5) 
 

- Radiation fields (Contrast, Fluoro Time, Radiation Dose, and Total DAP) now allow both 
blank and 0 values. Legacy cases where the value was 0 will be set to blank. 

 
- IMPACT Registry updates 

o Includes v2.0.1 updates - updated coding instructions and valid ranges for several 
fields, and some other checks. 

o Added PA systolic field in calculation overrides (if the IMPACT PA systolic shouldn’t 
come directly from the PA systolic site, enter it in the overrides section and it will 
transfer to IMPACT). 

o IMPACT transfer module. This will allow the IMPACT data for individual cases to be 
automatically saved (XML format) to a share folder (when the IMPACT data is 
saved or checked off) to share with third-party systems or for backup. This is a 
licensed feature. 

o Ability to import calculations files into the IMPACT 3 calculation fields during a 
legacy import. When loading the IMPACT case if any of the 3 calculated values 
exist from the cath report, they will override what’s in the IMPACT fields. If any 
values involved in the calculations are later changed on the Edit screen, the 
IMPACT fields will be overwritten when the cath is saved. 

o Added ability to import/export IMPACT xml files for individual cases. 
o Added validation for invalid device id’s based on the study type. 
o Fixes 

 Fixes when showing IMPACT procedures listing, so that folder names aren’t 
repeated. 

 Added additional v2 elements to IMPACT completeness check. 
 Fixed Genetic/Congenital Conditions and History of Risk Factors positioning 

in data reports. 
 Fixes when suggesting existing episode of care records with new cases 

(only the most recent will be shown). 
 Guamanian/Chamorro, Samoan, Other Island (sub choices of “Native 

Hawaiian/Pacific Islander”) would all be set to 0 (No) in the IMPACT 
submission file if “Native Hawaiian” wasn’t checked also. 

 The IMPACT status icons were incorrect when viewing by cath. It would 
show the status for the next cath in the list. 

 Fixes to validation checks. 
 PedCath will now automatically remove IMPACT follow-ups records when 

the associated Episode of Care is deleted. 
 Took out space from IMPACT follow-up submission file name. 

 
- C3PO Registry updates 

o Contains IMPACT v2 data elements in submission. 
 

- New EPIC Cupid inbound interface. This interface is accessed through the Direct Data 
Import Utility and will create a new patient and cath report (with any available cath-level 
fields), and generate a formatted, customizable procedure log.  

 
- Importing updates 

o Ability to show all licensed import files types at once to facilitate importing from 
multiple systems.  



o When importing a case you will be able to customize the default selections by using 
a configuration file (1 config file per import system type). This will allow you to 
define which sections are included (e.g. never pick up the staff list) in the initial 
import, and as well as overwrite options when importing into an existing case. This 
can be used to facilitate importing from multiple systems to specify what should 
come from each system. 

o Ability to automatically insert documents from the hospital templates as sections 
within the procedure notes. 

o Ability to automatically insert predefined headers as sections within the procedure 
notes, with optional text (up to 100 characters). 

o Ability to view the source code of a hemodynamic import file. 
o Ability to import Siemens Sensis files with Unicode encoding. 
o PedCath will import Microsoft Word (.docx) formatted files during the import if 

present. 
o Ability to choose staff overwrite options (merge vs delete and replace), when 

importing into an existing case. 
 
- Lumedx Apollo updates 

o IMPACT transfer module. 
 

- Document Manager Improvements 
o Ability to insert case diagrams/templates, case images, and hospital documents 

within the Document Editor. 
o Ability to reorder report documents and template documents (hospital/my 

documents) 
 

- Data Reports Updates 
 

- Expanded CVIS / Command line options  
o Ability to retrieve and update staff listing  
o Ability to import IMPACT data. 
o Added CVIS ID as export file field name (when CVIS interface is enabled). 

 
- Option to prevent patient demographics from being changed if there are one or more 

locked cases. (Set on the Report Locking tab in Administrative Options). 
 
- Added Thermo CI next to Thermo CO on the report (before it would only show if “Use 

Thermo CO” was checked in the overrides). 
 

- Fixed middle name fixer for patients with two, non-hyphenated last names. 
 

- The Billing Codes can now be edited even if the cath is locked, since they’re not included 
on the cath report. 

 
- Other usability improvements and fixes. 

 
Interface Changes 
 HL7 – Added 10001-11^TOTALDAP OBX segment. 
 
Administrative console 



- Added IMPACT 2 and some other tables to database maintenance reindexing. 
- Fixes to patient name formatting on some HIPAA logs. 

 
 
Version 8.4.2 
 

- Fixed Data Reports issues with CSV output 
o Fixed run time error Error 508-9: Subscript out of range when including Adverse 

Events in CSV output. 
o Added IMPACT 2 new procedures and adverse events to CSV output. 

- Fixed IMPACT user interface issues on Edit Screen 
o When first creating a PedCath cath report the IMPACT diagnoses screen may not 

show the new IMPACT 2 procedures boxes, and when viewing some of the existing 
procedure-specific data panels, some of the data fields are greyed out.  

o On the IR panel on the lower half of the Edit screen, several of the yes/no choices 
would not grey out or remove dependent choices until the case is saved and 
reloaded.  

 
(A work around for both issues in prior versions would be to save the cath report, exit 

and reopen the Edit screen). 
- Fixed IMPACT issue: The “Not Assessed” boxes were not saving on the Pulmonary 

Valvuloplasty study. 
 

 
Version 8.4.1 
 

- Several IMPACT Registry and other fixes. 
 

 
Version 8.4.0 
 

- IMPACT 
o Support for IMPACT Registry version 2 

 IMPACT v2 new data fields included in Data Reports, including 
followup data. 

o Ability to export multiple csv extracts at a time. 
o Removed IMPACT Adverse Events from the cath report. 
o Added Favorite Closure Methods list for quick selection. 
o Additional fixes and improvements 

- Added Total DAP field to cath report. The units are configurable in the options. 
Units for Rad Dose can be changed as well. 

- Exports 
o Added Advanced Text report options  

 Option to embed document text from Document Manager. 
 Option to suppress diagram export. 

o HL7  
 Ability to send a canceled message on cath deletion. 

o Ability to suppress superscripts in exports. 



- Imports 
o Siemens 

 Added support for Thermo CO  
 Fixes to the procedure log document creation. 

- Improvements to Document Manager Editor 
o Improved image handling 
o Added MS Word docx support for imports 
o Fixed issues when attaching a multipage PDF document to the cath report. 
o Other fixes and improvements 

 
 
Version 8.3.1 
 

- Support for Active Directory/LDAP user management and authentication. This is a 
licensed feature. White paper available. 

- IMPACT 
o Added option to allow Full-Edit users to submit the IMPACT data: 

 Under Options > Administrator tab > Personnel link       
 Check "Allow Full-Edit users to submit IMPACT data." 

o Dx Comments are now available to users of the IMPACT coding for the 
PedCath report.   

- C3PO export fixes.  
- Exports 

o XML exports (version 3.1) now include document exports and billing codes. 
Also includes the ability to export the diagrams and images in their original 
format. 

o HL7 export fixes.  
 Including institutional staff id with each PERSONNEL OBX segment. 
 The Embedded PDF will be forced to be within one segment by 

default. 
 Admin option to allow users to manually set the placer order number. 
 Added escape encoding to PDF report reference. 

- Imports 
o Fixed Siemens Sensis import error 147-9: Subscript out of range, when no 

conditions are included.  
o If the hemodynamic import path is relative to the PedCath network directory, 

it will be saved as a relative path, to facilitate database migration. 
o Improvements and fixes when importing PedCath XML files. Added ability to 

choose which sections are imported into existing cases. Ability to import 
XML version 3.1 files with documents and billing codes. 

- Data Reports 
o Better formatting of PDF results. 
o Fixed Cath ID and Patient ID columns to sort numerically rather than 

alphanumerically. 
o Added "Last Edited" field to Data Reports csv export in the cath fields 

section. 



- Ability to connect to a network directory at startup, from predefined list in a config 
file. 

- Billing Codes 
o Added ability to email the billing codes sheet. 
 
 

 
Version 8.3.0 
 

- C3PO Registry Export – PedCath will package a C3PO-formated transfer file from 
data entered into the PedCath report and IMPACT Registry module, to upload to 
the C3PO web site. All data common will be filled in automatically. This feature is 
included with the PedCath IMPACT Registry module. 

- Improved CVIS Integration. CVIS systems will be able to specify user and 
case/patient context and specify export parameters through the command line. An 
administrator option is available to permit the CVIS to manage staff and 
patient/case information directly.  PedCath can also directly load administrative 
tools including options, staff management, IMPACT administration/submission, and 
data reports. 

- Fixed report printing issues – under certain conditions the report would not be 
printed or show a preview. 

- Added Patient Merge feature. 
- XML export 3.0. Additional fields added. (Documentation available). 
- Ability to import a PedCath XML file. 
- IMPACT Registry improvements 

o Fixes to saving/validation. 
o IMPACT functions available on Edit Screen. 
o When using IMPACT Dx for PedCath Report Coding 

 Prior Surgeries and Prior Procedures added to the Dx form.  
 Recent procedures and surgeries now show up on the PedCath 

report with status post tag “(sp)”. 
o Recent Surgeries Date button fixed. 

- Improvements to import into current cath (cath section now checked by default). 
- Database backup tool added to the Administrative Console. 
- Added option to include hemodynamics and IMPACT Adverse Events in Data 

Reports CSV export.  
- Fixes to PedCath Live when running on multiple monitors. 
- Additional improvements and fixes. 

 
 
 
 
Version 8.2.3 
 

- New Accession Number and GUID fields. Both can be set from the import if 
available. The GUID field can also be auto generated for each case (configurable in 



the Misc Admin options). Both are available as fields in the export file name. There 
is a new Administrative Fields panel available from the Edit Screen that allows you 
to view those and other fields (View > Administrative Fields). 

- Added Account Number and Cath Number to document pages of the PDF report. 
- Data Reports updates 

o Added query for number of case Diagrams, Documents, and Images. 
o Added support to search for status post procedures. 

- Diagram Editor – added diagram save reminder. You can turn that on and set the 
time limit on the Options > Save Reminder (min) menu in the Diagram Editor. 

- Added reminder message to lock a report after changes have been made to the 
report and saved.  (At least 1 diagram must exist and 1 set of hemodynamics). This 
is a per user setting and can be turned on in the Options on the User tab. 

- Billing Code Module:  
o Support to retain code descriptions for codes that have been deleted.  
o Support for 2014 set updates (included). 
o Ability to import CPT codes (currently for Sensis only). 

- Admin Console Updates 
o Added database maintenance options to clean up import folder. 

- Demographics sync prompt during import. 
- Fixed a few issues. 

 
Version 8.2.2 
 

- ICD-10 support (see white paper for details). 
- Image Editor 

o New Crop Tool 
o Ability to make a duplicate copy of an image. 

- Report 
o Fixed issue with saving Global report options. 

- Data Reports 
o Fixed issue when searching for billing codes. 

- Imports 
o MacLab only: Ability to import from MacLab custom fields into PedCath 

hemodynamic or cath level elements (user’s guide available). 
o Ability to import into the OBR-4 field on a case by case basis, to be passed 

along in the HL7 export message. 
o Some other fixes and efficiency improvements. 

- IMPACT 
o Ability to import more than one file at a time. 

 
Version 8.2.1 

- Imports 
o Fixed issue causing PedCath to hang when loading a particular import case. 
o Other efficiency improvements (import mapping tables are loaded on 

demand). 
- A few minor bug fixes. 



 
Version 8.2.0 
 

- Report 
o Global Report Options – Administrators can set the report setup options for 

all users, and optionally allow users to save their own settings. 
o Auto-Select Documents – This will allow you to choose titles of documents in 

the document manager that will be automatically included in the report.  
(This will also determine what documents are included in the Text and HL7 
exports). 

- Imports 
o Ability to import into a current cath from the main Direct Data Import Utility 

tool. If a matching case is found you will be given a choice to import into an 
existing case or create a new one. 

o The Import Into Current Cath feature will auto-select measurement fields that 
will change throughout the case to be overwritten by default (such as total 
contrast, flourotime/dose). 

o Added option to allow you to turn off the auto-selection of images on the 
import screen. Contact Scientific Software for assistance setting this option. 

o When mapping staff, in addition to the login, the staff members’ names are 
now shown on the drop down list and are ordered by last name. 

o Fixed issue when adding new mappings for Siemens and Philips/Witt 
imports. New mappings would show up as blank lines. This was an issue 
with version 8.1 only. 

o Fixed mapping issue when importing HeartRate from Siemens systems. 
Earlier versions of PC8 would require the site name as part of the mapping 
(CN\AO Desc HR), now the default mapping of (CN\HR) will work, and will 
allow you to view the list of all sites measured.  

- Exports 
o Last edit time added as field for the export filename format. 

- IMPACT 
o Web update for closure methods and device lists. 
o Added Default options and other improvements when importing IMPACT 

data from other vendors. 
o Only Administrators may submit IMPACT data. 
o When viewing old cases, PedCath would occasionally say case data has 

been changed when you exit out of the Edit screen. This was related to 
IMPACT/PedCath shared data and has been fixed. 

o Fixed IMPACT report status updates when editing data on the Edit Screen. 
o Fixed validation/save issue when saving Demographics screen. 
o Fixes when deleting an IMPACT case (report status). IMPACT procedures, 

Dx, and events are left alone if you are using IMPACT coding for the 
PedCath report. 

o Any patients with Episodes of Care records found with no associated cases 
will be ignored when creating the submission file. This would cause a 



validation error on the NCDR web site. Those records will also be listed in 
the validation report. 

- Data Reports 
o Added IMPACT Post-Procedure section. 
o When searching for cases by procedure code, PedCath now ignores codes 

that have status-post set. 
o Previously when searching for Hispanic=False, null entries would be 

included. 
o Fixed issues with some cath date searches (inclusive searches, and 

month/quarter searches). 
- Several bug fixes 

o If "Use Thermo CO" is checked off on the override section, but there is no 
value set for the Thermo CO on the hemodynamics tab, you will get an error 
when exporting an HL7 file. 

o Fixed issue where Hemodyanamic values (such as ThermoCO and the 
blood gases) would not save when the value is 0.50 or below. This will affect 
any value on the Hemodynamic tab where a decimal value can be entered. 
(Most of the pressures and sats are integers and are not affected.) 

o Fixed issue when you load the move cath report function and the patient grid 
is sorted by MRN. 

- Added ability to set default page size and margins in the Document Manager. 
- Improved Unicode Support / Upgraded third-party controls. 
- The Studies (MAGIC) tab is now shown to be able to view legacy data.  
- Updates to HeartSuite interface. 
- Support for Multilingual (coming soon). 

 
 
 
Version 8.1.1 
 

- IMPACT 
o Fixed IMPACT Edit Screen save issue.  

- Exports 
o Added patient name fields to the export file name configuration. 

- Administrative Console 
o Support for Scientific Software to inspect/modify the database during remote 

assistance sessions. 
- Update Wizard 2.1.1 release  

o Shows current version of PedCath used on your network.  Will allow you to 
upgrade to your current network version through the web update feature. 

o Support for upgrading the multilingual version of PedCath. 
o A few minor fixes. 

 
 
Version 8.1 

- New Data Reports module 



o Expanded data elements available, including hemodynamic and IMPACT 
data. 

o Ability to load query results on the Browse screen. 
- IMPACT updates 

o IMPACT pre-procedure and procedure data now easily accessible from the 
Edit screen. 

o Reenabled IMPACT submission/export for non-admins 
o Surgeries included in Dx list. 
o Performance improvements when loading closure methods list. 

- Imports: 
o Ability to import into User/Institutional sites. 
o Ability to set cath-level field mappings (e.g. cath number). 
o Ability to import mappings from a file. 
o MacLab Only: Bug fix where angio images would not import correctly (bug in 

version 8.0.5 only). 
- Administrative Console 

o Ability to back up and clear out HIPAA logs based on a date range. 
- Document (PDF) Sweep function (licensed feature) -  this module will allow 

PedCath to automatically import a document narrative from your hemodynamic into 
the PedCath document manager. The narrative may not be available when the 
hemodynamic import is first run – the sweeper module will facility the transfer when 
the narrative becomes available and will sync the document to the PedCath report 
if it is later updated on the hemodynamic system 

- Ability to configure the fourth header line on the report. 
- The Order number is now shown on the Edit Screen status bar if it was set during a 

hemodynamic import. 
- Several UI fixes. 
-  

Version 8.0.5 
- IMPACT Updates 

o Includes coding instructions update. Use the Auxilary 3 field to specify 
whether there was a surgery prior to the cath during the hospital visit. 

o Ability to choose the hemoset sent to IMPACT on the Edit Screen. The first 
set is chosen by default. 

o If you are using Thermo Cardiac Output for the PedCath report (is checked 
off in the override section), the Thermo Cardiac Index will be sent to 
IMPACT for the Cardiac Index value. 

o A batch middle name checker will run prior to creating a submission file, to 
help move middle names to the middle name fields. 

o Checks database schema for number of decimals for hemodynamics sent to 
IMPACT. 

o Ability to sync data definition tables from the network. 
o Speed enhancements to loading cath grid when report checkoff is turned on. 
o Added a lock to prevent users from modifying IMPACT data concurrently, 

which without could case database issues. 
o Fixed a few typos. 



o Added Patient level Other ID field and administrative option to link it to the 
MRN. 

- Imports: 
o Ability to register labs to import from. 
o Auto-increment cath number support for hemodynamic imports. 
o Siemens Only: Ability to handle multi-column documents for the Sensis 

procedure log. 
o Philips/Witt Only: Middle names getting deleted during import. 
o McKesson Only: Allow mapping for account number. 

- Exports: 
o HL7: The numeric prefix was missing from the text-based report wrapper:    

10012-01^TEXTREPORT 
o HL7: The top OBR header could be missing some fields based on your 

export configuration. 
- An Administrative login is now required to run a database update. 
- Fixed diagrams changing to greyscale when saving. 
- Rad Dose will not be listed on the report if it’s 0. 
- Fixed issue with initial form positioning. 
- Various other bug fixes. 

 
Version 8.0.4 

- HL7 Updates 
o Ability to send the HL7 file to a different folder location than the other 

exports. 
o Ability to embed the Text-based report within the HL7. 

- IMPACT 
o Fixes to Devices and Closure Methods csv import. 

- Fixes to Login Framework relating patient locks when PedCath is improperly shut 
down.  Admin Console will now show records with patient locks even if there is not 
a staff member associated. 

 
 

Version 8.0.3 
- IMPACT fixes 

o Fixed issue when printing validation results report. 
o Several validation fixes 
o Fixed issue when using IMPACT codes for PedCath report. 

- Fixes/improvements to Login Framework (PedCath and Administrative Console). 
- Exports: Additional fields now available for export file name format. 
- Fixed installation issue regarding ImageMan8 dependancies (IMACTX80.OCX). 
- Better checks for forms loaded off screen, due to shared user environments. 
- Other minor fixes. 

 
 
Version 8.0.2 

- IMPACT module updates 



o Added a field to indicate that an IMPACT case is complete. This check-off is 
for user-tracking only and is ignored by the IMPACT submission Module. 

o Added the ability to override the systemic systolic and diastolic pressures 
(on the PedCath Edit screen calculation overrides, for the IMPACT 
hemodynamic set) 

- HL7: Options to choose what is used for the Filler and Placer order number. 
- Added the ability to flip each diagram horizontally, for Dextra-Cardia patients. 
- Fix to vein/artery report overrides. 
- DB update 3.0.2 

 
 

Version 8.0.1 
- Added completeness icons for data sections in the IMPACT module. 
 

Version 8.0 
- Added IMPACT Registry module. 
- Ability to add PDFs to the Document Manager and print with the cath report. 
- Import improvements: 

o Ability to import more than one cath per day, if a patient has multiple caths 
on the same day. 

o Added automatic import for the Philips/Witt PDF narrative. 
- Exporting improvements: 

o Option to include documents from the Document Manager within the HL7 
and Text files 

o Option to strip out all of the HL7 OBR segments except for the first. 
o Option to rename the first HL7 segment 
o Option to create a PDF-only HL7 export, that contains the PDF link or 

Base64 embed, and not the discrete case data. 
- Ability to change diagnostic code sets, while retaining your old codes. 
- Administrative Console updates: 

o Will allow you to see what hosts have PedCath open (even if not logged in), 
and boot them out of the system. 

 
Version 7.7.3 

- Improved the Import Into Current Cath feature. You can now run the Direct Data 
Import Utility from the Edit Cath screen at any time to bring in any missing data for 
the current case, or bring in document/image resources that were not available 
when the report was first started. PedCath will allow you to check off the desired 
sections to bring in and set overwrite options for cath and hemodynamic level data 
fields.  

- Added institutional Staff ID field. 
- Better support for mixed language workstation environments. 
- Added option to prevent users from adding staff on the Cath Edit screen. 

 
 
Version 7.7.2 



- Web/CD installation for Atlas updates. 
- Added 2 x 3 layout for report images. 
- Fixed issue where the Image Manager editor would not always load the selected 

image (issue with 7.7.1 only). 
- HL7/XML fixes. Greater support for exporting to HIS systems. 
- Several hemodymanic import fixes/improvements. 
- Extended radiation dosage field to the thousands place (xxxx.xx).*  

 
* If you are currently at version 7.7.1 you will need to rerun the 2.6.2 database upgrade to get 

the radiation dosage field extension. Choose the “Clear DB Version Data” option in the 
Administrative Console maintenance section, and open PedCath to run the update. 

 
Version 7.7.1 
- Enhanced report options 
 - Ability to select what Image Manager images will appear on the report and retain those 

choices for future printouts. 
 - Option to print the hemodynamics rather than calculations on summary pages with more 

than one associated hemoset. Also added the ability to hide empty hemodynamics grids. 
 
- New cath-level radiation dose field. The account number is also now shown on the Edit 

Screen. 
 
- Support for additional Atlas variations for every diagram (Left SVC to Right Atrium, Left SVC 

to Coronary Sinus, and Right Aortic Arch).  An updated atlas library is required to use this 
feature. 

 
- For AE users: Ability to enter a description for unlisted adverse events.  
 
 
 
Version 7.7.0 
- MAGIC improvements 

- Batch submission tool 
- Summary report.   
- Ability to edit MAGIC studies in a resizable window. 
- Support for additional controls 

 
- Added Direct Data interface for Horizon Cardiology Hemo system. 
 
- Added configurable age-based default to the Oxygen Consumption calculator. 
 
- Administrative Console 1.1.5   

- Ability to set up an institutional-wide upgrade. By specifying an update file, PedCath 
will update itself upon startup, everywhere on the network. You can also block 
users from upgrading to a later version on their local machine.  PedCath 7.6.9 or 
later is required for the updates to be installed automatically. 



 
- Batch case lock feature gives you the option to lock your cases only, where you 

had a given role. 
 
- Update Wizard 2.0.9  

- Ability to install an update silently. 
 
- Fixed issue where the account number may have an initial value when creating a new cath 

report. 
 
- Added the ability to save any report page as a clipboard image. 
 
- Cleaned up Options dialog. 
 
- Account Number shown on report, if used. 
 
- Added the ability to add multiple images at once into the Image Manager. 
 
Version 7.6.8 
- Added ability to manually send out files configured on your auto-export list.  This can be 

useful to send out a preliminary report or to resend locked reports. This feature can be 
found on the File menu on the Edit Screen. 

 
- Added ability to move a cath report from one patient record to another.  This can be useful if 

a patient was imported with incorrect demographics. This feature can be found on the Edit 
menu on the Browse screen and requires administrative privileges. 

 
-  Added option to prompt for password to lock a case. A different user may also lock the 

case. Options for these features can be configured from the “Cath Locking” section of the 
administrative options. 

 
- Added ability to retry a failed database operation and to disconnect/reconnect before 

retrying. 
 
 
Version 7.6.7 
- Diagram recovery feature. 
- Several changes to the HL7 export. Please refer to the HL7 specification for details. 
- Added a data field for the Account Number. This field can be set through the Edit menu on 

the Cath Edit screen. This number can be brought in through a hemodynamic import and 
there is an administrative option to require this field be set before an export. 

- Option to print diagnosis and comments only once. 
- Fixed staff filter for Camtronics and Philips hemodynamic system imports. 
 
 
Version 7.6.6 



- Support for the new Mullins alternate/wide diagrams with extended pulmonary arteries.  
- Added ability to install supplemental atlas diagrams directly from the web or a package file. 
- Manual save now uses the same file name format as the auto-export 
- Fixed issues with the auto-increment cath number feature. 
- Added the ability to link or embed the PDF in the XML and HL7 files. The embed feature will 

encode the report in Base64 and requires that Internet Explorer 6 is installed. 
- Fixed issues when importing more than one Word document during a hemodynamic import. 
- Fixed issue with cath number when multiple cases are imported. 
 
Version 7.6.5 
- Expanded command line options. 
- Fixed image imports from the MacLab (issue with earlier versions of 7.6 only). 

 
Version 7.6.4 
- PedCath now supports the ability to run in a multi-user application server/remote desktop 

type environment (such as over Citrix Presentation Server). Several options must be set to 
enable this functionality. 

 
Version 7.6.3 
- The auto-export feature can be configured to export the report both when it is saved and 

when it is locked (rather than one or the other). 
 
Version 7.6.2 
 
Turn Calculation of Qep On/Off for All Users: PedCath Administrators can set the 

Calculate Qep option on or off for all users and control whether individual users can 
override the global setting. 

Global Export Path: A PedCath Administrator can set an export path that will be used by 
each installed PedCath application at the institution. Doing so will prevent non-
Administrators from changing the path. Please note that it is the Administrator's 
responsibility to ensure that the path is valid on each machine where PedCath is installed. 

Dual-Logo Header Layout: You can now have a custom logo appear on either side of the 
header on PedCath's printed reports. 

Improved Siemens Sensis Import: Users of the Siemens Sensis hemodynamic monitoring 
system can now import key images and wave forms into PedCath's image manager. 

Improved International Support for Imports: We can now configure PedCath's import utility 
to recognize non-English strings in the import file. 

Miscellaneous fixes and minor features: 
- Fixed bug 126-9: Error reading an import file if it contains an empty hemodynamic set. 
- Fixed bug 125-381: Invalid property array index when reading import files. 
- Fixed bug: if upgrading from version prior to 7.5, the database upgrade will fail the first time. 

Running it a second time it should go through successfully. The errors the first time don’t 
cause any problems. 

- Fixed bug: Qp and Qs values were not showing up in the extended calculations. 



- Fixed bug: HL7 export - some OBX segments started at 2 instead of 1 
- Added ability to extend cath number field length. Contact Scientific Software for more 

information. 
- Repositioned controls on Oxygen Consumption Calculator and View Calculations Window. 
- Fixed bug: XML auto-export was saving the version 1.0 XSL file 
 

Version 7.6.0 
 
Diagnosis/Procedure Comments: You can now enter free-text comments on the 

Diagnosis/Procedures Window. You can choose to print the comments or the list of 
diagnoses/procedures, or both. There is a new 'Copy' button to the right of the selected 
items list that will copy the entire list to the clipboard. 

 
To configure printing options: 
Report Setup Window > Options tab > Dx/Comment Options... button 
 

Improved Data Import: We've improved the default mappings for importing data from 
Siemens, Witt, Camtronics and GE hemodynamic monitoring systems. We've also made 
changes to the way the Import Utility tracks individual user preferences. 

 
There is a new Administrator option to "Allow user mapping" (Tools > Options > 

Administrator tab > Import). This feature is now disabled by default, due to problems 
caused by the format of the hemodynamic data export files. In most cases, user 
preferences are handled sufficiently by the improved default mappings. 

 
Please contact us for updated import maps if you're having trouble importing data. 
 

Longer Usernames:  PedCath usernames (a.k.a Logins) may now be up to 20 characters in 
length. 

 
Advanced FTP Export: PedCath can now send the cath report via FTP in HTML, PDF and 

plain text formats in addition to XML and HL7. PedCath now supports Secure FTP, public 
key authentication, and proxy servers. 

 
The Export Options (Tools > Options > Administrator tab > Export) have changed. The 

available export formats are listed in a table. There is a column of checkboxes to 
enable (checked) or disable (unchecked) 'Save As...' If 'Save As...' is enabled for a 
particular export format, users will be able to save the report in that format by clicking 
'Save As...' on the Report Setup Window. There is also a column for Auto Export. If 
Auto Export is enabled for a particular format, that format will be exported when the 
cath report is saved or locked, according to the 'Auto export is triggered when...' 
configuration option. 

 
To configure FTP export profiles, click the FTP button (under 'Advanced Export 

Options'). You can now have as many FTP export profiles as you want. You can set 
any FTP export profile to auto export. If FTP auto export is enabled, then all FTP 
export profiles set to auto export will be triggered when auto export is triggered. If 



Save As FTP is enabled, then users will be able to manually export a cath report 
using any of the available FTP profiles, regardless of the profile's Auto Export 
setting. 

 
XML Export Version 2.1:   A PedCath administrator can configure the XML export engine to 

export diagrams and images with the XML file. Links to the exported files are included in 
the XML document. The administrator can choose to export diagrams and images in 
JPEG, PCX or PNG format and specify size constraints. Version 2.1 includes all data for a 
case, including additional fields added in this release. 

 
XML Export Version 2.1 includes extra data: Adverse Events (MAGIC participants only), 

Diagnosis/Procedure comments and references to exported images and diagrams 
when applicable. 

 
Version 2.1 is backward-compatible with version 2.0. All sections and elements found in 

version 2.0 are still included in version 2.1. 
 
To configure the XML export, go to Tools > Options > Administrator tab > Export > XML 

button. You can export cath images (viewable in the Image Manager) and/or heart 
diagrams. For each, you can specify: 

 - the image format: PCX, JPEG or PNG 
 - for JPEG, the quality 
 - maximum height and/or width in pixels (aspect ratio is always preserved) 
 
The image/diagram filenames are the same as the XML file itself, except that "-tx" is 

appended, where t is the type ("i" for image, "d" for diagram) and x is the order ("1", 
"2", ...). These additional files are also referenced in the XML document, along with 
their dimensions. Please contact us for the XML Export v2.1 Specifications. 

 
Auto-Increment Cath Number:   A PedCath administrator can configure PedCath to 

automatically use the next cath number when a user creates a new cath record. The 
administrator can specify the Cath Number prefix, suffix and minimum length. 

 
To configure the Auto-Increment Cath Number feature, go to Tools > Options > 

Administrator tab > Misc. If this feature is enabled, users cannot edit the Cath 
Number. PedCath will automatically enter the next number in sequence when a user 
adds a new cath. Due to the fact that the Cath Number field may be alpa-numeric, 
there is no way for PedCath to accurately determine the largest cath number in the 
database. Therefore, you must manually enter the next cath number when 
configuring the feature. 

 
You may specify an alpha-numeric prefix and/or suffix for the cath number. The 'Next 

No.' field must be an integer value. You can also specify a minimum length for the 
cath number. PedCath will insert zeros in front of the integer portion of the cath 
number if the cath number is less than the minimum length value. 

 



Standardized Adverse Event Codes:   PedCath now includes a standardized Adverse 
Event code list based on the EPCC code set and pending IPCCC standards. This option is 
automatic for MAGIC study participants, available by request to other multi-center 
collaborations. 

 
In earlier versions of PedCath, it was possible to require that each new cath report have 

at least one complication code ('Force complications'). This option was required to 
be enabled for MAGIC users. In version 7.6.0, Adverse Event codes are required the 
same way that complication codes were required before. 

 
Complication codes remain in the various code sets for backward compatibility.  Each 

user is warned that the complication codes are obsolete upon opening the 
Diagnoses/Procedures Window. 

 
PedCath functions exactly as it did before for non-MAGIC participants. 
 

Multiple Study Groups:  A study can be associated with one or more multi-center 
collaborations (rather than just MAGIC), and each group has its own export settings. 
Configuration and reporting tools are now available in the administrative options. You 
must obtain a group configuration file to be a member of a particular group. 

 
MAGIC and other collaborations require a license file from Scientific Software. Please 

contact us if you are interested. 
 
HL7 Changes: We have made changes to PedCath's HL7 export format. If you are using 

the HL7 export, please contact us for details. 
 
Miscellaneous fixes and minor features: 
- Philips hemodynamic interface available 
- Systeria HeartSuite interface available 
- Checks to make sure that the export filename format string does not exceed the maximum 

storable length (50 characters) 
- Additional data fields included in HTML, XML 2.1, XML 1.0, plain text and HL7 export 

formats and the printed report/PDF 
- Timestamp now appears correctly in the HL7's MSH segment 
- Improved support for running different versions of PedCath on the same machine 
- Improved Philips and Camtronics interfaces 
- Diagrams (if they exist) are associated with hemodynamic sets when importing 

hemodynamic data into an existing cath report. 
- Error reports are now assigned a Case Number 
- Staff role list populates correctly after adding a new case 
- Document Manager can now import plain text files (*.txt)  
- Document Manager can now import documents with 0-width margins 
- Data Reports allow searching on RECORD_ID and PAT_ID 
- Comments textbox now has a vertical scrollbar 
- Fixed problems with the hemodynamic set printing options 



 
 


